When viewing the CDN page for Jira, the Automation For Jira plugin gives a warning as possibly incompatible

Description

Issue Summary
When a user on Jira DC 8.3 or greater navigates to the Content Delivery Network page, the Automation for Jira plugin produces a warning of possible incompatibility with CDN usage.

Steps to Reproduce
On a Jira DC instance 8.3 or greater, open the Content Delivery Network page (Jira Administration> System > Advanced > Content Delivery Network).
Notice a card warning user of A4J compatibility with the CDN.
Tried with A4J version 6.0.16 installed and also upgraded to 7.1.5. Both had same issue.
Expected Results
A4J can be used on Jira instances using CDNs.

Actual Results
On the Content Delivery Network Screen a card with the following text was shown to the user:

"
User-installed apps may not be compatible
The following apps rely on deprecated code which can lead to problems when caching assets. * Automation for Jira

"

See attached screenshot.

Workaround
Currently there is no known workaround.

Environment

None

Assignee

Mark Chaimungkalanont

Reporter

Mark Chaimungkalanont

Labels

None

Links

1

Priority

Medium
Configure